Update Ruby shipped with OS X

Number:rdar://13450321 Date Originated:19-Mar-2013 09:23 AM
Status:Duplicate/8973915 Resolved:
Product:Mac OS X Product Version:10.8.3
Classification:Enhancement Reproducible:Always
Seriously I'm sick of my colleagues complaining that Apple has not updated the version of Ruby that ships with the OS X for 9 YEARS now.

ruby --version
ruby 1.8.7 (2012-02-08 patchlevel 358) [universal-darwin12.0]

According to Wikipedia (http://en.wikipedia.org/wiki/Ruby_(programming_language)#Ruby_2.0) Ruby 2.0 was released on February 24, 2013. Ruby 1.9 was released in December 2007.

I think most developers would be delighted if Apple updated the bundled Ruby to version 1.9, they would be ecstatic if Apple went "all-in" and adopted ruby 2.0 in the next major OS Version.

Please Apple, *PLEASE* this is really a request that causes little work (have an Intern do it!) but big rewards. Goodwill from the developer community, fame, wealth, good fortune, good karma…. and my ever lasting gratitude for having one less reason for people whine around me that you are supposedly boycotting any development language other than Objective-C.


i support this radar ..

and it isnt very handy to install rvm all the time.

Please note: Reports posted here will not necessarily be seen by Apple. All problems should be submitted at bugreport.apple.com before they are posted here. Please only post information for Radars that you have filed yourself, and please do not include Apple confidential information in your posts. Thank you!