Swift: Rename 'Generator' protocol to 'Enumerator'
||Date Originated:||08-Jun-2014 01:11 PM|
I feel like the `Generator` protocol is the source of a lot of confusion, especially when used with `Sequence`. I can’t help but feel like a simple rename of `Generator` to `Enumerator` would clarify this protocol’s intended behavior.
Steps to Reproduce:
1. Implement `Sequence`
Expect the related protocol names to be descriptive enough to make it obvious what their intended use case is
The use of the `generate()` function in `Sequence` along with a `Generator` sequence leads to confusion, and it’s not immediately clear what the `Generator` is used for.
Reports posted here will not necessarily be seen by Apple.
All problems should be submitted at bugreport.apple.com before they are posted here.
Please only post information for Radars that you have filed yourself, and please do
not include Apple confidential information in your posts. Thank you!