lldb-rpc-server hangs apps it tries to attach to

Number:rdar://33277953 Date Originated:12-July-2017 04:24 PM
Status:Duplicate/33146919 Resolved:
Product:Developer Tools Product Version:Version 9.0 beta 3 (9M174d)/macOS High Sierra 10.13 Beta (17A306f)
Classification:Serious Bug Reproducible:
Xcode is unable to debug my macOS apps sometimes because it appears that the process of attaching to the app is causing it to hang. This makes it impossible to attach the debugger to apps in any way.

Steps to Reproduce:
1. Build and run an app.
2. Wait for Xcode to say that it is "running" the app.
3. Kill lldb-rpc-server.
4. Wait for lldb-rpc-server to relaunch.
5. Try to attach to the app's process.
6. Kill lldb-rpc-server.
7. Quit the app.

Expected Results:
LLDB successfully attaches at steps 2 and 5 and the app continues running as usual.

Observed Results:
At step 2, the app does not appear to launch (in actuality it's likely hung up by the attaching process before it can spawn a window).
At step 3 the app finally "launches" and runs as normal, however the debugger is not attached.
At step 5 the app hangs.
At step 6 the app recovers and behaves normally.

Version 9.0 beta 3 (9M174d)/macOS High Sierra 10.13 Beta (17A306f)

I think this is a regression from the last beta, since I don't remember this being an issue before.

MacBook Pro (Retina, 13-inch, Early 2015) running macOS High Sierra 10.13 Beta (17A306f)


Please note: Reports posted here will not necessarily be seen by Apple. All problems should be submitted at bugreport.apple.com before they are posted here. Please only post information for Radars that you have filed yourself, and please do not include Apple confidential information in your posts. Thank you!